Jump to content


Photo

The mystery of "Willy Takes a Trip"


  • Please log in to reply
4 replies to this topic

#1 jetsetdanny

jetsetdanny

    Advanced Member

  • Contributor
  • 2,132 posts

Posted 07 April 2015 - 08:47 PM

I hope this topic belongs here, as it refers to one of the JSW remakes for the ZX Spectrum.

 

 

Willy Takes a Trip (2000) is a beautiful game by Geoff Eddy, notable for its technical innovations (modifications to the JSW48 game engine and patch vectors).

 

But is it completable? Has anyone ever completed it?

 

 

I have recently tried to play Willy Takes a Trip to completion and so far I have failed to do so. It seems to me that the game is not completable. However, I may be wrong. I would like to share my doubts and ask for everyone's help in establishing the truth.

 

 

There are 213 items ("thingees") to collect in the game. I have managed to collect 184 of them and then got stuck.

 

 

The 29 items which I have not been able to collect are:

 

 

- 3 items placed together in "The Store Room".

 

I can't see any way to collect them other than teleporting in from another room or a patch vector opening the wall or providing some other way to reach them.

 

 

- The leftmost item in "The Arches of Despair, I fear", the item in "Nineteen - Not Out!", the middle item in "The Windowbox" and the two items in "Oh no! CLIFF".

 

All of the above belong to a section of the game map which I am unable to access. It looks to me like it should be accessed by going up from "A Quiet Corner to rest in" - but that's impossible to do, AFAICT.

 

 

- The middle and the two left items in "The Promised Land (tropical)".

 

I cannot access this part of the room, either from the left side, or coming up from "Willy's Drinking Licence", or from the lower left of "The Promised Land (arctic)". Am I missing something?

 

 

- The upper item in "Weeds", the 5 items in "Don't Inhale, Billy", the 5 items in "Good Skunk" and the 7 items in "...".

 

This is another section of the game map which I don't know how to access. It looks like the player should be able to drop down into "Weeds" from the room above, but no room has such an exit, AFAICT in JSWED. 

 

 

Andrew Broad once mentioned in the Yahoo! MM/JSW Group (message 6482, third paragraph from the bottom) the possibility that thanks to one of the patch vectors in Willy Takes a Trip collecting all the items in one room causes a wall to disappear in another. I haven't observed any such phenomenon in the game, which doesn't mean, however, that it's not there. If it is, it might indeed offer access to an otherwise inaccessible section of the game map. Does anyone know if it occurs, and if so, in which room(s)?

 

 

Some other problems appear in Willy Takes a Trip, namely the necessity to sacrifice one life in order to collect the items in "Psychic Bread and Butter", one life in "Reception Antechamber" and two lives in "Womflechompies". These problems, however, do not affect the completability of the game.

 

 

So, is Willy Takes a Trip completable? Any help or comments?

 



#2 Spider

Spider

    DEC (HL)

  • Administrator
  • 3,961 posts

Posted 08 April 2015 - 11:33 AM

I'll take a look at this to see.

 

Map is here


Changing order to chaos since 1984

#3 jetsetdanny

jetsetdanny

    Advanced Member

  • Contributor
  • 2,132 posts

Posted 08 April 2015 - 08:44 PM

Thanks, Spider  :) .

 

The map is very useful, indeed, as they all are. Pavel Pliva has done a great job mapping JSW games and hundreds of others.
 
I only posted the question yesterday and it turns out I can give all the answers today (I truly didn't expect that!), thanks to some assistance from Andrew Broad and John Elliott at the Yahoo! Group, and thanks to the tips in the text file accompanying the game given by Geoff Eddy himself as well as some intense analysis and playtesting. It only occurred to me today to consult the text file (I should have done so long before!) and the answers are all there, basically, although in a somewhat cryptic form.
 
Here are the solutions to the questions I put forward:
 
 
1. "The Store Room"
 
There is a green object above the "S" in the room name which seems to be a Fire cell, because it kills you if you jump against it from below. However, when you drop onto it from above, from the right hand side, it teleports you to an invisible platform in "Downhill". You have to walk right and then, before hitting an invisible Fire cell which limits the platform from the right (there is another one on the left as well), you have to jump up and you will get teleported back into "The Store Room" where you are now able to collect the three previously inaccessible items.
 
2. "A Quiet Corner to rest in"
 
There is a blue horizontal guardian in that room which should catch a trained player's attention because it moves erratically, kind of. This guardian is, in fact, a horizontal lift which allows you to cross the upper middle part of the room from left to right. Then you can cross its upper part back from right to left, exit upwards into "Nineteen - Not Out!" and collect all of the previously inaccesible items in this and three other rooms.
 
 
3. Reaching the upper part of "Weeds"
 
There is a teleporter at the bottom-right corner of "The Hideaway".which takes you to the bottom-right corner of "Iain's Stomach" (I think it must be activated only at a certain point in the game, because the teleportation doesn't happen when you first collect the items there - AFAICT without double checking). From there you can make your way up to the uppermost platform on the right of "Iain's Stomach", which in turn teleports you to the upper part of "Weeds". Once you are there, you can explore the whole zone which, according to Geoff's notes, "pertains to a certain recreational herb" :-) .
 
As a result, Willy Takes a Trip is indeed toilet-completable. I am now working on a streamlined RZX recording of the game for the RZX Archive.
 
I didn't really expect the mystery to be solved so soon. What a day :-) .
 

And what a delightful challenge Willy Takes a Trip is - hats off to Geoff, wherever you are!  :) 



#4 Spider

Spider

    DEC (HL)

  • Administrator
  • 3,961 posts

Posted 12 April 2015 - 12:42 PM

Excellent and thank for the writeup. :)


Changing order to chaos since 1984

#5 jetsetdanny

jetsetdanny

    Advanced Member

  • Contributor
  • 2,132 posts

Posted 12 April 2015 - 06:17 PM

Thank you, and here's the RZX recording. The game can be completed with a loss of three lives, in the rooms:
 
"Reception      Antechamber" [27];
 
"Womflechompies" [43];
 
"Psychic Bread and Butter" [57].
 
In all cases you have to lose a life because it is impossible to get back down safely from the upper part of the room after collecting an item / items there.
 
Additionally, there is a time limit in "Womflechompies" imposed by the arrow which shoots the yellow duck (which occurs after it in the guardian instance list). However, perhaps it might just be possible to get out of the room after collecting the items (or at least the rightmost item - and if you could do that, you could collect all of them by going after each of them individually after re-entering the room) - it can't be verified though, as there is no way to get down safely from the third-from-the-bottom Water cell on the left side of the room.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users